Logo by Fiery - Contribute your own Logo!

END OF AN ERA, FRACTALFORUMS.COM IS CONTINUED ON FRACTALFORUMS.ORG

it was a great time but no longer maintainable by c.Kleinhuis contact him for any data retrieval,
thanks and see you perhaps in 10 years again

this forum will stay online for reference
News: Visit the official fractalforums.com Youtube Channel
 
*
Welcome, Guest. Please login or register. January 19, 2019, 02:36:23 PM


Login with username, password and session length


The All New FractalForums is now in Public Beta Testing! Visit FractalForums.org and check it out!


Pages: [1]   Go Down
  Print  
Share this topic on DiggShare this topic on FacebookShare this topic on GoogleShare this topic on RedditShare this topic on StumbleUponShare this topic on Twitter
Author Topic: Timeline not loading?  (Read 475 times)
0 Members and 1 Guest are viewing this topic.
Patryk Kizny
Global Moderator
Fractal Fertilizer
******
Posts: 372



kizny
WWW
« on: October 17, 2015, 12:43:08 PM »

So I made my animation using timeline editor.
Presets are saved in the code, not in external file (that option does not work for me).
When I reload the project, I can't seem to find a way to get my animation back. I see the metadata for keyframes in the code, but the timeline won't populate and and there's no anim playing.
Is there anything special that needs to be done to read animation?
Logged

Visual Artist, Director & Cinematographer specialized in emerging imaging techniques.
cKleinhuis
Administrator
Fractal Senior
*******
Posts: 7044


formerly known as 'Trifox'


WWW
« Reply #1 on: October 17, 2015, 01:15:24 PM »

i think you need to load the preset in the property window
Logged

---

divide and conquer - iterate and rule - chaos is No random!
Patryk Kizny
Global Moderator
Fractal Fertilizer
******
Posts: 372



kizny
WWW
« Reply #2 on: October 17, 2015, 07:41:01 PM »

Figured that out. You need to do the following:
1) Turn timeline ON before compiling.
2) Compile
3) Load a preset
Logged

Visual Artist, Director & Cinematographer specialized in emerging imaging techniques.
_revers_
Conqueror
*******
Posts: 138



« Reply #3 on: October 18, 2015, 11:10:57 PM »

I'm glad you managed to solve your problem. But I don't understand why presets in external files don't work for you.
Do you have some errors using them? What operating system do you use?
Logged
Patryk Kizny
Global Moderator
Fractal Fertilizer
******
Posts: 372



kizny
WWW
« Reply #4 on: October 19, 2015, 12:46:19 PM »

When saving to file is enabled (and it defaults to it) whenever I save a preset all presets are being replaced by the reference to a .presets file in the code.
So the UI seems to work and the reference is appearing. However, what does not work is that the preset file is never created and I'm getting some errors in the console or log window. I'll try to detail it shortly.
I am on Win 7 Ultimate.

What would be handy also would be to add some saving automation or a shortcut for saving the timeline. Currently timeline is sort of independent, so the only way to save timeline correctly is to click the [save] icon on the timeline then save the main file. Yesterday I lost a few hours of animating because I accidentally clicked 'compile' and noticed it compiled the last version of the project which cause all my animation work lost.

I also noticed there's a bunch of synthclipse commands available to assign keyboard shortcuts to in main eclipse menu, but a lot of them is missing. Is there any way to get around it to add shortcus (say for save timeline)? Or you would need to make them available externally explicitly?
Logged

Visual Artist, Director & Cinematographer specialized in emerging imaging techniques.
_revers_
Conqueror
*******
Posts: 138



« Reply #5 on: October 19, 2015, 10:31:25 PM »

However, what does not work is that the preset file is never created and I'm getting some errors in the console or log window. I'll try to detail it shortly.
I am on Win 7 Ultimate.
Strange, Window 7 is the OS I'm using. It is the most tested by me OS. Could you give me the error messages so I could investigate it?

so the only way to save timeline correctly is to click the [save] icon on the timeline then save the main file. Yesterday I lost a few hours of animating because I accidentally clicked 'compile' and noticed it compiled the last version of the project which cause all my animation work lost.
If  "the main shader file" is already saved you just need to press [save] button to save timeline/animation (no need to save  "the main shader file" again). Just try to get used to saving files always after making some modifications. It is a good habit.

Also you don't need to use [save] icon from Timeline View to save animations. "Save" button from Uniform Controls View will do exactly the same thing (if the Timeline is enabled).

I also noticed there's a bunch of synthclipse commands available to assign keyboard shortcuts to in main eclipse menu, but a lot of them is missing. Is there any way to get around it to add shortcus (say for save timeline)? Or you would need to make them available externally explicitly?

To get the list of all key bindable Synthclipse commands go to Window -> Preferences -> General -> Keys and in "type filter text" field type "Synthclipse". Unfortunately there is no "Save preset" command, but I will add it in the next Synthclipse release. Every missing command I need to add manually.
« Last Edit: October 19, 2015, 11:20:58 PM by _revers_ » Logged
Pages: [1]   Go Down
  Print  
 
Jump to:  

Related Topics
Subject Started by Replies Views Last post
parameters not loading Other / General Discussion gateman45 1 1832 Last post October 08, 2012, 04:24:46 AM
by lenord
Timeline! Feature Requests bfarn 3 467 Last post January 11, 2014, 02:02:48 PM
by lukesleftleg
Continuous crashes loading every previously saved fractal (1.3.14/1.3.15) Mandel Machine istinn 3 545 Last post April 17, 2016, 05:55:20 AM
by stardust4ever
Timeline idea Fragmentarium 3dickulus 2 282 Last post September 13, 2016, 07:21:35 AM
by M Benesi
Timeline for 2.12? Mandelbulber Kyzia 1 542 Last post August 09, 2017, 02:19:32 PM
by Buddhi

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines

Valid XHTML 1.0! Valid CSS! Dilber MC Theme by HarzeM
Page created in 0.104 seconds with 28 queries. (Pretty URLs adds 0.005s, 2q)