Logo by Mahmut - Contribute your own Logo!
News: Visit us on facebook
 
*
Welcome, Guest. Please login or register. March 23, 2017, 03:15:35 PM


Login with username, password and session length



Pages: [1]   Go Down
  Print  
Share this topic on DiggShare this topic on FacebookShare this topic on GoogleShare this topic on RedditShare this topic on StumbleUponShare this topic on Twitter
Author Topic: Error when compiling mandelbulber2-2.10 on debian jessie  (Read 76 times)
0 Members and 1 Guest are viewing this topic.
freakiebeat
Forums Freshman
**
Posts: 11


WWW
« on: March 21, 2017, 12:19:14 AM »

I am trying to compile mandelbulber2-2.10 on a debian jessie machine.

When I run the command "qmake mandelbulber.pro" from the makefiles directory I get the following:

Project MESSAGE: Use sndfile library for WAV files
Project ERROR: Unknown modules(s) in QT: multimedia

Any help to solve this problem would be appreciated, Thanks.
Logged

A Flame A Day Keeps Psychosis Away - http://v3d0.sheepserver.net/cgi/best?menu=designer&p=2
Buddhi
Fractal Iambus
***
Posts: 849



WWW
« Reply #1 on: March 21, 2017, 06:10:42 PM »

Have you followed instructions from README file:

Code:
2. COMPILING
------------

packages needed to run: libqt5gui5, libpng16-16, libgsl2, libgomp1 libqt5multimedia5 libqt5multimedia5-plugins
packages needed to compile: build-essential, qt5-default, libpng-dev, qttools5-dev, qttools5-dev-tools, libgsl-dev, libgomp1 qtmultimedia5-dev libqt5multimedia5-plugins libsndfile1-dev


On Ubuntu, Debian stable (jessie) or Mint:
sudo apt-get install build-essential libqt5gui5 qt5-default libpng12-0 libpng-dev qttools5-dev qttools5-dev-tools libgomp1 libgsl-dev libsndfile1-dev libqt5multimedia5-plugins

On Debian testing (stretch)
sudo apt-get install build-essential libqt5gui5 qt5-default libpng16-16 libpng-dev qttools5-dev qttools5-dev-tools libgomp1 libgsl-dev qtmultimedia5-dev libsndfile1-dev libqt5multimedia5-plugins


Then:

cd makefiles
qmake mandelbulber.pro
make all
cd ..

for gamepad support qt is required in version 5.7 and above

2.1. Alternative compilation with cmake

note: compilation with cmake is only beta and not feature complete

in order to compile OpenEXR with cmake the ECM should be present
to install on debian/ubuntu:
sudo apt-get install extra-cmake-modules

3. INSTALLATION
---------------

please type:
./install

(installation script will do compilation also)
Logged

Buddhi
Fractal Iambus
***
Posts: 849



WWW
« Reply #2 on: March 21, 2017, 06:14:26 PM »

By the way on Debian Jessie there could be the problem with compilation. It has quite old Qt libraries and some of parts of the code could be not compiled properly. It's recommended to use up-to-date version of Ubuntu or Debian Stretch (testing)
Logged

Pages: [1]   Go Down
  Print  
 
Jump to:  

Related Topics
Subject Started by Replies Views Last post
Error 500 - Internal server error Discuss Fractal Forums tomot 9 1628 Last post April 22, 2011, 04:06:24 PM
by lenord
Mandelbulber in Debian testing repository Mandelbulber Buddhi 0 1001 Last post September 15, 2011, 08:22:10 PM
by Buddhi
Compiling Animation? Mandelbulber atemporal 6 1995 Last post October 11, 2012, 03:37:30 AM
by JohnVV
Debian Port feature request Daeurth 0 182 Last post April 04, 2013, 02:10:14 AM
by Daeurth
Mandelbulber2 error message "Fractal ui file can't be loaded" Help & Support Pete 1 37 Last post July 22, 2016, 08:44:39 PM
by mclarekin

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines

Valid XHTML 1.0! Valid CSS! Dilber MC Theme by HarzeM
Page created in 0.958 seconds with 28 queries. (Pretty URLs adds 0.073s, 2q)