Logo by mauxuam - Contribute your own Logo!

END OF AN ERA, FRACTALFORUMS.COM IS CONTINUED ON FRACTALFORUMS.ORG

it was a great time but no longer maintainable by c.Kleinhuis contact him for any data retrieval,
thanks and see you perhaps in 10 years again

this forum will stay online for reference
News: Visit us on facebook
 
*
Welcome, Guest. Please login or register. October 14, 2019, 06:52:24 AM


Login with username, password and session length


The All New FractalForums is now in Public Beta Testing! Visit FractalForums.org and check it out!


Pages: [1]   Go Down
  Print  
Share this topic on DiggShare this topic on FacebookShare this topic on GoogleShare this topic on RedditShare this topic on StumbleUponShare this topic on Twitter
Author Topic: [1.06] lowmem switch causes segfaults when increasing resolution.  (Read 967 times)
0 Members and 1 Guest are viewing this topic.
junkdog
Guest
« on: July 19, 2011, 06:47:46 PM »

Hi,

I've been trying to get the lowmem switch to work, but whatever I do it segfaults as soon as I increase the resolution above 800x600 and hit render. Lowering the resolution works fine though.

Crash from rendering at 900x700, all other parameters from default.fract (so no fog or other fancy stuff).
Code:
$ gdb /usr/bin/mandelbulber core
<snipped>
Core was generated by `mandelbulber -lowmem'.
Program terminated with signal 11, Segmentation fault.
#0  0x0000000000408b3a in PutPixelVolumetricFog (ptr=0x7fff34c2cac0) at ../src/cimage.hpp:104
104             inline void PutPixelVolumetricFog(int x, int y, sRGB16 pixel) {if (x >= 0 && x < width && y >= 0 && y < height) complexImage[x + y * width].volumetricFog = pixel;}

Dist is Ubuntu 11.04, x86-64. I haven't had a chance to try it out under windows.
« Last Edit: July 19, 2011, 06:49:23 PM by junkdog » Logged
Buddhi
Fractal Iambus
***
Posts: 895



WWW
« Reply #1 on: July 24, 2011, 09:40:29 AM »

Hi

Thank you for bug report. I forgot to update -lowmem mode after adding of some new features. If you are able to compile the program, please find attached corrected one of source files. This version should work properly.

* Render3D.cpp.zip (15.96 KB - downloaded 104 times.)
Logged

junkdog
Guest
« Reply #2 on: July 29, 2011, 05:05:20 PM »

Thanks for the fix! I haven't had a chance to try it out yet (been away on a mini-vacation and have otherwise been busy), but I'll give it a go during the weekend.

BTW - and a little OT - how do you generate the makefiles? I checked out the svn repository, but it didn't contain the makefiles that are included with the releases.
Logged
Pages: [1]   Go Down
  Print  
 
Jump to:  

Related Topics
Subject Started by Replies Views Last post
Help with resolution Mandelbulb 3d Pacoski 5 732 Last post March 20, 2011, 03:55:59 AM
by Pacoski
1 min FullHD HI resolution 3d stereo. Movies Showcase (Rate My Movie) slon_ru 0 634 Last post September 09, 2011, 03:45:08 PM
by slon_ru
box count resolution is the slope ... right ? General Discussion cKleinhuis 2 983 Last post December 10, 2012, 05:20:42 PM
by cKleinhuis
high resolution mandelbrot Format, Printing & Post Production Lillevilse 1 1529 Last post January 19, 2013, 09:21:03 PM
by cKleinhuis
Switch Mode UltraFractal tm2123 9 1450 Last post March 01, 2015, 11:35:03 PM
by cKleinhuis

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines

Valid XHTML 1.0! Valid CSS! Dilber MC Theme by HarzeM
Page created in 0.119 seconds with 28 queries. (Pretty URLs adds 0.009s, 2q)