Logo by Maya - Contribute your own Logo!

END OF AN ERA, FRACTALFORUMS.COM IS CONTINUED ON FRACTALFORUMS.ORG

it was a great time but no longer maintainable by c.Kleinhuis contact him for any data retrieval,
thanks and see you perhaps in 10 years again

this forum will stay online for reference
News: Check out the originating "3d Mandelbulb" thread here
 
*
Welcome, Guest. Please login or register. September 22, 2020, 02:02:07 PM


Login with username, password and session length


The All New FractalForums is now in Public Beta Testing! Visit FractalForums.org and check it out!


Pages: [1]   Go Down
  Print  
Share this topic on DiggShare this topic on FacebookShare this topic on GoogleShare this topic on RedditShare this topic on StumbleUponShare this topic on Twitter
Author Topic: 3d navi  (Read 1487 times)
Description: Getting 3d navi to work
0 Members and 1 Guest are viewing this topic.
haltenny
Safarist
******
Posts: 96


« on: May 04, 2011, 02:54:31 PM »

This may be common knowledge to advanced users so it's intended to help more the beginner. For a long while I didn't use the 3d navi because I had so much trouble with it. It was the normal stuff like it not showing the same thing that is in the main window, and an inability to navigate in general. I understood that you could check the 'fixed zoom and steps' box but that gives unsatisfactory results. In my case, the problem was usually caused because I was inside a part of the structure I was exploring. If I navigated there in the main window and then went to the 3d navi I couldn't go anywhere because I was somehow inside a piece of the structure or bumping up against something.

This inability to navigate also may crop up when loading old parameters in newer versions. The solution I found is to simply turn on cutting. Find out which plane you are looking at. For instance I was working from some old parameters and the 3d navi showed nothing remotely like what the main window showed. By turning on each cutting plane individually and adjusting the value, I determined I was looking at the x plane. I then kept tweaking the cut value up and down until I found out where I was on that plane. In this case I was cutting at -0.15 on the x plane. A setting of -0.14 cut into my piece more whereas a setting of -0.16 had no effect. (Negative numbers cut less, positive numbers cut more) Once I determined where the piece was cut at, I reloaded the piece into the 3d navi, it appeared exactly the same in the 3d navi and main window, and I was able to navigate with no problem.

I am assuming that even though I originally didn't have cutting turned on, the piece was being cut due to zmid values. Hope this helps someone. I can't tell you how many times I abandoned the 3d navi because of this...

Edit: Above I should have said, "I am assuming that even though I originally didn't have cutting turned on, the piece was being cut due to one of the z values, start, mid or end, I'm not sure which..."
« Last Edit: May 04, 2011, 03:17:30 PM by haltenny » Logged
Kali
Fractal Supremo
*****
Posts: 1138


« Reply #1 on: May 04, 2011, 03:23:49 PM »

I didn't have before too much trouble as you mentioned, but I'm forced now to use "fixed zoom and steps" mode with the Jesse implementation of the Kaliset/Kaliducks formula, and when this mode is on, a set of arrows shows up to adjust the zoom, so you walk until the cutting begins, move a little backwards, and then get closer using that without causing cuts in the fractal wink
Logged

|</\|_|
░░░░░░░

http://fractkali.deviantart.com/
Pages: [1]   Go Down
  Print  
 
Jump to:  

Related Topics
Subject Started by Replies Views Last post
Navi refresh Mandelbulb 3d bib 3 1306 Last post March 06, 2011, 05:53:05 PM
by bib
3D Navi wouldn't show the main rendering content at all - ? Mandelbulb 3d Sfumato 12 2476 Last post August 21, 2011, 04:46:02 PM
by wmauzey
Julia - full set of value boxes in navi ( and cutting to navi) feature request toxic-dwarf 3 1265 Last post August 11, 2012, 02:03:28 PM
by toxic-dwarf
Mandelbulb3Dv1793 3d Navi Sliding Zooms Sometimes? Mandelbulb 3d art.cjbarnaby.com 1 959 Last post October 23, 2012, 01:39:00 AM
by art.cjbarnaby.com
Send values from Navi window v1.7 bug reporting brandpeter 2 735 Last post March 01, 2013, 10:04:28 AM
by brandpeter

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines

Valid XHTML 1.0! Valid CSS! Dilber MC Theme by HarzeM
Page created in 0.119 seconds with 28 queries. (Pretty URLs adds 0.009s, 2q)