Logo by Kaliyuga - Contribute your own Logo!

END OF AN ERA, FRACTALFORUMS.COM IS CONTINUED ON FRACTALFORUMS.ORG

it was a great time but no longer maintainable by c.Kleinhuis contact him for any data retrieval,
thanks and see you perhaps in 10 years again

this forum will stay online for reference
News: Check out the originating "3d Mandelbulb" thread here
 
*
Welcome, Guest. Please login or register. November 20, 2019, 08:34:37 PM


Login with username, password and session length


The All New FractalForums is now in Public Beta Testing! Visit FractalForums.org and check it out!


Pages: [1]   Go Down
  Print  
Share this topic on DiggShare this topic on FacebookShare this topic on GoogleShare this topic on RedditShare this topic on StumbleUponShare this topic on Twitter
Author Topic: Image moves when setting the main reference  (Read 390 times)
0 Members and 1 Guest are viewing this topic.
Dinkydau
Fractal Senior
******
Posts: 1616



WWW
« on: March 02, 2017, 02:46:59 PM »

When I check "Reuse reference" and then use "Set main reference" the image moves a little. What could cause this?

I tried some more things. When I zoom in a few times from an original depth D (such as 9.61963041900E111) and then insert the depth D again in the location window, the image is not centered at where I zoomed in on as I would expect. No matter where I zoom to, when I set the depth to a specific value I get the same image, as if it's not influenced by the coordinates. Even when I change the coordinates radically (manual manipulation of the digits), what I see doesn't change much. When I don't set the depth and only zoom in and out and move the image around, the results do seem to be consistent.
« Last Edit: March 02, 2017, 07:02:46 PM by Dinkydau » Logged

Kalles Fraktaler
Fractal Senior
******
Posts: 1458



kallesfraktaler
WWW
« Reply #1 on: March 07, 2017, 12:00:50 PM »

When I check "Reuse reference" and then use "Set main reference" the image moves a little. What could cause this?

I tried some more things. When I zoom in a few times from an original depth D (such as 9.61963041900E111) and then insert the depth D again in the location window, the image is not centered at where I zoomed in on as I would expect. No matter where I zoom to, when I set the depth to a specific value I get the same image, as if it's not influenced by the coordinates. Even when I change the coordinates radically (manual manipulation of the digits), what I see doesn't change much. When I don't set the depth and only zoom in and out and move the image around, the results do seem to be consistent.
So, you selected reuse reference, and while having that active, you selected set main reference and clicked somewhere else?
So the program things the position where you clicked is the position of the reference, but the reference was not recalculated.
So the reason is that the location of the reference is not where the program thinks it is smiley
Logged

Want to create DEEP Mandelbrot fractals 100 times faster than the commercial programs, for FREE? One hour or one minute? Three months or one day? Try Kalles Fraktaler http://www.chillheimer.de/kallesfraktaler
http://www.facebook.com/kallesfraktaler
Dinkydau
Fractal Senior
******
Posts: 1616



WWW
« Reply #2 on: March 07, 2017, 04:02:19 PM »

Then maybe I don't understand what reuse reference and set main reference do exactly. Some problems can be prevented by unchecking reuse reference, then using set main reference and then rechecking reuse reference. By doing so, the image doesn't move, however, zooming in and then setting a lower depth manually does still cause the image not to be centered around the coordinates. Does the program ignore the coordinates and use those of the reference or something?
Logged

Kalles Fraktaler
Fractal Senior
******
Posts: 1458



kallesfraktaler
WWW
« Reply #3 on: March 07, 2017, 08:29:38 PM »

Then maybe I don't understand what reuse reference and set main reference do exactly. Some problems can be prevented by unchecking reuse reference, then using set main reference and then rechecking reuse reference. By doing so, the image doesn't move, however, zooming in and then setting a lower depth manually does still cause the image not to be centered around the coordinates. Does the program ignore the coordinates and use those of the reference or something?
When "Reuse reference" is active, the reference is simply never re-calculated.
If you zoom in at the side of the reference, and have this active, the view may look nice but series approximation will eventually distort the image since the distance from the reference get too far, since the reference is probably far out of screen.
As we saw on claude's and knighty's experiments with finding a theoretical way of using series approxiation, having too low threashold makes too many iterations to be skipped and the image is still looking nice but distorted.

Logged

Want to create DEEP Mandelbrot fractals 100 times faster than the commercial programs, for FREE? One hour or one minute? Three months or one day? Try Kalles Fraktaler http://www.chillheimer.de/kallesfraktaler
http://www.facebook.com/kallesfraktaler
Dinkydau
Fractal Senior
******
Posts: 1616



WWW
« Reply #4 on: March 08, 2017, 07:56:04 PM »

Okay, now I know set main reference doesn't work with reuse ference enabled.

The distortion is not what I mean. It's that when reuse reference is enabled, changing the coordinates manually doesn't seem to affect the image much and I think that's weird. It can't be explained by distortion because dragging the image around works fine. I could set the coordinates to something completely different like (0, 0) and it still wouldn't affect the image.
Logged

Pages: [1]   Go Down
  Print  
 
Jump to:  

Related Topics
Subject Started by Replies Views Last post
Setting a parameter in all keyframes at once... Mandelbulber nameinuse2 2 1220 Last post January 25, 2011, 07:56:58 PM
by Buddhi
Bug in color setting with eyedropper Mandelbulber meegja 0 930 Last post August 31, 2011, 09:22:30 PM
by meegja
Frame of Reference I Fractal Science Kit Gallery Ross Hilbert 0 339 Last post July 23, 2012, 05:14:28 PM
by Ross Hilbert
Changes when sending a navigation image back to "main"...how come? Help & Support chaos_crystal 3 180 Last post April 04, 2013, 12:22:47 AM
by chaos_crystal
One reference to rule them all (new) Theories & Research quaz0r 0 178 Last post September 09, 2016, 10:56:22 PM
by quaz0r

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines

Valid XHTML 1.0! Valid CSS! Dilber MC Theme by HarzeM
Page created in 0.159 seconds with 29 queries. (Pretty URLs adds 0.01s, 2q)