Logo by mauxuam - Contribute your own Logo!

END OF AN ERA, FRACTALFORUMS.COM IS CONTINUED ON FRACTALFORUMS.ORG

it was a great time but no longer maintainable by c.Kleinhuis contact him for any data retrieval,
thanks and see you perhaps in 10 years again

this forum will stay online for reference
News: Visit us on facebook
 
*
Welcome, Guest. Please login or register. June 21, 2018, 08:17:18 PM


Login with username, password and session length


The All New FractalForums is now in Public Beta Testing! Visit FractalForums.org and check it out!


Pages: [1]   Go Down
  Print  
Share this topic on DiggShare this topic on FacebookShare this topic on GoogleShare this topic on RedditShare this topic on StumbleUponShare this topic on Twitter
Author Topic: FragM 2.0  (Read 1186 times)
0 Members and 1 Guest are viewing this topic.
3dickulus
Global Moderator
Fractal Senior
******
Posts: 1558



WWW
« on: August 09, 2017, 06:54:01 AM »

just fixed a typo in Float4Widget::setValue() that caused absolute havoc, my humblest apologies, the fix has been applied to the github sources.
Logged

Resistance is fertile...
You will be illuminated!

                            #B^] https://en.wikibooks.org/wiki/Fractals/fragmentarium
Tas_mania
Forums Newbie
*
Posts: 8



WWW
« Reply #1 on: August 18, 2017, 01:36:41 PM »

Hi 3dickulus.
I can't see any information on how to build/compile FragM from Github. I use Linux Ubuntu and have installed all the libs from the Syntopia version but can't find a compile or build script in FragM.
Please help?  huh?
Logged
3dickulus
Global Moderator
Fractal Senior
******
Posts: 1558



WWW
« Reply #2 on: August 19, 2017, 01:49:23 AM »

Code:
git clone https://github.com/3Dickulus/FragM

cd FragM/Fragmentarium-Source
mkdir build
cd build
cmake-gui ..
                      ->configure
                     -> generate
                     -> quit
make -j4
make install

set the install prefix in cmake-gui before running make install, it will install to /usr/local by default, user home folder is OK.
if you have OpenEXR installed then set USE_OPEN_EXR = ON (checked in CMake-GUI) default = OFF
if your gfx card supports GL4.0 or greater then set NVIDIAGL4PLUS = ON (checked in CMake-GUI) default = ON
you can use the cmd line version of cmake too
Code:
cmake ..
but that will use the defaults

this should work for Mac OSX, Windows(mingw) and Linux wink
Logged

Resistance is fertile...
You will be illuminated!

                            #B^] https://en.wikibooks.org/wiki/Fractals/fragmentarium
Tas_mania
Forums Newbie
*
Posts: 8



WWW
« Reply #3 on: August 19, 2017, 03:22:21 AM »

Thanks very much. I like to build with a classic install sequence. I realise I need QT5 rather than Qt4 but thats easy.
Cheers  wink
Logged
3dickulus
Global Moderator
Fractal Senior
******
Posts: 1558



WWW
« Reply #4 on: August 19, 2017, 04:16:49 AM »

You can also use QCreator or QMake if you like by loading Fragmentarium.pro or...

Code:
cd FragM/Fragmentarium-Source
qmake
make install

...this will install to /usr/local/ and should also work on Mac OSX, Windows(mingw491) and most flavors of Linux
Logged

Resistance is fertile...
You will be illuminated!

                            #B^] https://en.wikibooks.org/wiki/Fractals/fragmentarium
M Benesi
Fractal Schemer
****
Posts: 1075



WWW
« Reply #5 on: August 19, 2017, 05:16:48 AM »

Cool. cheesy  When I get a chance I will bite into it... cheesy
Logged

3dickulus
Global Moderator
Fractal Senior
******
Posts: 1558



WWW
« Reply #6 on: August 19, 2017, 06:05:56 AM »

@ M Benesi  just now trying to put together a wiki at https://en.wikibooks.org/w/index.php?title=Fractals/fragmentarium&stable=0&redirect=no that describes the 3 flavors of Fragmentarium, acquiring the source and compiling or getting executable packages, documenting menu items, dialogs, pre-processor commands, uniform widgets, scripting commands, mouse  control and hot keys.

Still need to get more familiar with github and it's features so I can, hopefully, provide binaries for popular OSs smiley
Logged

Resistance is fertile...
You will be illuminated!

                            #B^] https://en.wikibooks.org/wiki/Fractals/fragmentarium
M Benesi
Fractal Schemer
****
Posts: 1075



WWW
« Reply #7 on: August 19, 2017, 09:43:45 PM »

lol.  I am glad you're at it.  cheesy
Logged

Tas_mania
Forums Newbie
*
Posts: 8



WWW
« Reply #8 on: August 25, 2017, 02:22:08 AM »

I can build FragM on Ubuntu 16.04 but when I start the program I get a segmentation fault.
backtrace
#0  0x0000000000480727 in Fragmentarium::GUI::MainWindow::init() ()
#1  0x00000000004819dc in Fragmentarium::GUI::MainWindow::MainWindow(QSplashScreen*) ()

I will try to turn off the splash screen and hope there are no other errors.I never used Qt Creator before.

Question: Do I need a GeForce FX or Quadro FX to support OpenEXR for Fragmentarium?
http://www.openexr.com/
Logged
3dickulus
Global Moderator
Fractal Senior
******
Posts: 1558



WWW
« Reply #9 on: August 25, 2017, 06:47:20 AM »

difficult to diagnose without more info, PM me some details
make sure the Misc folder contains splash.png and that your working folder ( the place you run FragM from) contains the Misc folder

you will also need to #define USE_OPEN_EXR and NVIDIAGL4PLUS before compile

I run a GeForce GTX 760 but it should run on most gfx cards that can use GL shader language

developed with OpenEXR 2.1  has no relationship with what gfx card you have
Logged

Resistance is fertile...
You will be illuminated!

                            #B^] https://en.wikibooks.org/wiki/Fractals/fragmentarium
mclarekin
Fractal Senior
******
Posts: 1739



« Reply #10 on: August 25, 2017, 09:29:41 AM »

@ 3dickulus. About when you left click? on the slider and the adjustment numbers appears. Is it possible to increase the maximum number that can be entered? Thanks smiley
Logged
3dickulus
Global Moderator
Fractal Senior
******
Posts: 1558



WWW
« Reply #11 on: August 26, 2017, 01:13:24 AM »

Absolute max for this value is 2,147,483,647 (max int)
Line 80 in VariableWdget.h change 10000 to 21474836 or any value that gets the desired result wink

Why is this ? QSlider is int only so must be scaled to match the float min/max set by the user, usually a small value like -1.0 to 1.0 needs to be mapped to a reasonable int range for the slider. The calculated default for a given range should set single step to about 0.01 automatically. When mapping a small range, a too large slider step multiplier value will render it useless.

I see that the auto scale calculation gives a larger result than the max in the popup so I will increase it in  the sources to something like 1,000,000,000
Thanks mclarekin, I would have left it if you hadn't brought it up  A Beer Cup
Logged

Resistance is fertile...
You will be illuminated!

                            #B^] https://en.wikibooks.org/wiki/Fractals/fragmentarium
charPixel
Forums Newbie
*
Posts: 1


« Reply #12 on: December 18, 2017, 05:13:33 PM »

Hi

I have managed to compile FragM using Qt5.9 and am currently exploring the App, and so far I'm loving it!! A Beer Cup

I started with the tutorials and they are still a bit cryptic for me but that's fine for now

however tutorial no 4   texture.frag . I managed to get it to load in an image and I can run the tunnel animation
however I cant render anything out, I just end up with completely black images .

I have managed to render out frames from tutorial 01 so I know I'm doing something right!!
tutorial no 1 is not using a texture ,so do I have to do something different to render out loaded Textures??? huh?

any chance of some brief instructions on how to render out from a loaded texture.

I have a few more questions but I will leave them for now.

Regards

Logged
Pages: [1]   Go Down
  Print  
 
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines

Valid XHTML 1.0! Valid CSS! Dilber MC Theme by HarzeM
Page created in 0.305 seconds with 27 queries. (Pretty URLs adds 0.013s, 2q)