Logo by bib - Contribute your own Logo!

END OF AN ERA, FRACTALFORUMS.COM IS CONTINUED ON FRACTALFORUMS.ORG

it was a great time but no longer maintainable by c.Kleinhuis contact him for any data retrieval,
thanks and see you perhaps in 10 years again

this forum will stay online for reference
News: Visit the official fractalforums.com Youtube Channel
 
*
Welcome, Guest. Please login or register. October 27, 2020, 08:26:26 AM


Login with username, password and session length


The All New FractalForums is now in Public Beta Testing! Visit FractalForums.org and check it out!


Pages: [1]   Go Down
  Print  
Share this topic on DiggShare this topic on FacebookShare this topic on GoogleShare this topic on RedditShare this topic on StumbleUponShare this topic on Twitter
Author Topic: DE Raytracer issues  (Read 724 times)
0 Members and 1 Guest are viewing this topic.
Patryk Kizny
Global Moderator
Fractal Fertilizer
******
Posts: 372



kizny
WWW
« on: June 09, 2015, 05:11:33 PM »

Hey,

I was playing around with DE Raytracer and original quaternion Julia.
Latest build of package from 3Dickulus, no modified code, everything as is out of the box.

I noticed 2 strange behaviours:

1) It looks like the focal plane is not actually perpendicular to the camera optical path (and the screen rendering).
It's clearly visible on this image:
http://labs.kizny.com/image/120362591875


Sort of weird. Any ideas?

2) Artifacts on the rendered image
Across most of the rendered images I see some sort of artifacts highlighted on the image.
It is persistent across a series of frames and the areas slightly move over time across the image.



Any ideas on the reason for it?
Logged

Visual Artist, Director & Cinematographer specialized in emerging imaging techniques.
Syntopia
Fractal Molossus
**
Posts: 681



syntopiadk
WWW
« Reply #1 on: June 09, 2015, 09:36:27 PM »

Not sure about the DOF. I tried to render a couple of tests (attached) in legacy Fragmentarium, and they looked as I would expect. On your image the orientation is not clear to me, so I can not really tell if it looks wrong.

Many kinds of artifacts may arise. Try adjusting the Dither (perhaps even disabling it) or setting the FudgeFactor to something less than 1. Banding issues also appear routinely. Artifacts can also be caused by specular highlights. Some fractals may also exhibit NaN-values at certain settings (which always result in non-antialiased black pixels).


* test.jpg (92.62 KB, 1109x616 - viewed 197 times.)

* test2.jpg (37.3 KB, 903x597 - viewed 183 times.)
Logged
3dickulus
Global Moderator
Fractal Senior
******
Posts: 1558



WWW
« Reply #2 on: June 10, 2015, 03:25:00 AM »

it looks ok to me for a focal plane that is very thin and an aperture that is large, the math for this is (ciiw) all in the shader.
try making Aperture a bit smaller and InFocusWidth a bit bigger.
do an animation where the object rotates or the camera floats around it and observe the look of the focal plane, when in motion it will be very apparent and may lend a clue if there is something wrong.
Logged

Resistance is fertile...
You will be illuminated!

                            #B^] https://en.wikibooks.org/wiki/Fractals/fragmentarium
Pages: [1]   Go Down
  Print  
 
Jump to:  

Related Topics
Subject Started by Replies Views Last post
Health issues & animations Art Discussions « 1 2 » Bent-Winged Angel 17 4435 Last post July 13, 2011, 09:11:32 PM
by casey5
New Mandelbulb 3D - iterations issues Help & Support Fiery 5 999 Last post January 31, 2011, 01:00:13 PM
by Jesse
New issues with navigator lighting Mandelbulb 3d Fitz 4 1355 Last post February 09, 2011, 12:41:48 AM
by Fitz
Installation issues mac os Mandelbulber scheven_architect 10 4409 Last post April 28, 2011, 09:53:13 PM
by scheven_architect
Having issues with parameters Mandelbulb 3d webTech 4 732 Last post February 01, 2015, 05:06:36 PM
by lenord

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines

Valid XHTML 1.0! Valid CSS! Dilber MC Theme by HarzeM
Page created in 0.158 seconds with 28 queries. (Pretty URLs adds 0.01s, 2q)