Logo by Khaotik - Contribute your own Logo!

END OF AN ERA, FRACTALFORUMS.COM IS CONTINUED ON FRACTALFORUMS.ORG

it was a great time but no longer maintainable by c.Kleinhuis contact him for any data retrieval,
thanks and see you perhaps in 10 years again

this forum will stay online for reference
News: Support us via Flattr FLATTR Link
 
*
Welcome, Guest. Please login or register. January 19, 2019, 02:11:11 AM


Login with username, password and session length


The All New FractalForums is now in Public Beta Testing! Visit FractalForums.org and check it out!


Pages: 1 [2] 3   Go Down
  Print  
Share this topic on DiggShare this topic on FacebookShare this topic on GoogleShare this topic on RedditShare this topic on StumbleUponShare this topic on Twitter
Author Topic: [Solved] BUILD Fragmentarium on Windows  (Read 4732 times)
0 Members and 1 Guest are viewing this topic.
Syntopia
Fractal Molossus
**
Posts: 681



syntopiadk
WWW
« Reply #15 on: July 04, 2013, 06:03:29 PM »

Hi Vinz.

It seems you are mising the 'moc' files. These "Meta object files" files should be generated by Qt.

- What happens if you right-click "MainWindow.h" and click 'compile'?
- Have you set the 'QT4DIR' environment variable?
- Are there any files in the 'tmp/moc/release_shared' library?

I'm using Qt 4.6.3 myself, but I can try installing a newer version to see if there are any issues.

Wrt the old VS2008 version - I installed the VS2013 beta last week, but I really couldn't stand the upper casing of the menus and the new flat layout, so I had to switch back.
Logged
vinz
Iterator
*
Posts: 154


« Reply #16 on: July 04, 2013, 06:14:34 PM »

HAAAAAAAAAAA !! Great to see you there Syntopia cheesy  A Beer Cup A Beer Cup A Beer Cup A Beer Cup

1.- Compiling MainWindow done successfully.
2.- Yes i've set the QT4DIR -> "c:\QT\4.8.5"
3.- No there isn't any file in "tmp/moc/release_shared " also i manualy created the folder "release_shared " that was not present.


* Screenshot - 04_07_2013 , 18_12_11.jpg (36.04 KB, 1196x184 - viewed 343 times.)
« Last Edit: July 04, 2013, 06:23:44 PM by vinz » Logged
Syntopia
Fractal Molossus
**
Posts: 681



syntopiadk
WWW
« Reply #17 on: July 04, 2013, 06:31:09 PM »

I just tried installing Qt4.8.5 and it worked fine - I got tons of the macro redefinition stuff though.
I had to copy the new QtCore4.dll, QtGui4.dll, QtOpenGL4.dll files to the "Build - Windows\release" to run it.

1.- Compiling MainWindow done successfully.

And it was the ".h" file you compiled? Did it write something like 'Moc'ing MainWindow' in the console?
Logged
vinz
Iterator
*
Posts: 154


« Reply #18 on: July 04, 2013, 06:35:44 PM »

Thanks you so mucchhh Syntopia ! grin

- Yest it was MainWindow.h ( as there was no option to compile in right click menu i used (F7 compile from generating menu )
- in the picture attached to previews post there is a line that said : " 1>Moc' ing MainWindow "
« Last Edit: July 04, 2013, 06:39:50 PM by vinz » Logged
Syntopia
Fractal Molossus
**
Posts: 681



syntopiadk
WWW
« Reply #19 on: July 04, 2013, 06:42:25 PM »

Oh - I see there is an error in the project file.

Can you try switching from "Debug" to "Release" mode, and building the project?

It seems some moc files are only generated in Release mode. After having run once in Release mode, it should be possible to switch to debug mode though.
Logged
vinz
Iterator
*
Posts: 154


« Reply #20 on: July 04, 2013, 06:46:20 PM »

HAHAHHHAAAAAAAA ! It seems to have been worked .... it told me qt4 dll is missing but i suppose that i've to put them at the good place Grin with closed eyes
Logged
vinz
Iterator
*
Posts: 154


« Reply #21 on: July 04, 2013, 06:49:00 PM »

YESSSSSSSSSSSSSSSSS it seems to work !!! no errors in compiling .. i need to try the result !! THANNNNNNNNNNNNNNNNNNNNNNKSSSSSSSSS YOUUUUUUUUUUUUUUUUUUUU
 A Beer Cup A Beer Cup A Beer Cup A Beer Cup A Beer Cup A Beer Cup A Beer Cup A Beer Cup A Beer Cup A Beer Cup


* Screenshot - 04_07_2013 , 18_47_50.jpg (71.32 KB, 1196x247 - viewed 435 times.)
Logged
vinz
Iterator
*
Posts: 154


« Reply #22 on: July 04, 2013, 06:55:28 PM »

THAT WORK !!!!!!!!!!!!! i've replaced qt dll ..... I'm Sooooooooo HAPPY i was loosing hope !   THAnks you Thanks you Syntopia .... you made my day  cheesy
edit: also thanks you very much 3dickulus and Elphinstone cheesy

i'm pretty sure this topic will help more people, it can't be more noob than me hahahaha grin
« Last Edit: July 04, 2013, 07:01:17 PM by vinz » Logged
vinz
Iterator
*
Posts: 154


« Reply #23 on: July 04, 2013, 08:27:13 PM »

Syntopia don't kill me, i've increased subframe maximum value to 9000 for tiles render and preview sliders cheesy, hahahah my first tweak  grin
Logged
3dickulus
Global Moderator
Fractal Senior
******
Posts: 1558



WWW
« Reply #24 on: July 04, 2013, 09:53:40 PM »

Excellent !!! I'm impressed. My solution would be to install linux evil
don't forget to grab the latest version of my hack, I've allowed the webserver to display the fragmentarium folder so you can see the date stamp and file size

I can't wait to see some animations, I suppose I should put together a How-To or something.

G'donya! A Beer Cup
Logged

Resistance is fertile...
You will be illuminated!

                            #B^] https://en.wikibooks.org/wiki/Fractals/fragmentarium
cKleinhuis
Administrator
Fractal Senior
*******
Posts: 7044


formerly known as 'Trifox'


WWW
« Reply #25 on: July 04, 2013, 09:58:15 PM »

nice, can you provide an executable?
Logged

---

divide and conquer - iterate and rule - chaos is No random!
vinz
Iterator
*
Posts: 154


« Reply #26 on: July 04, 2013, 10:06:42 PM »

Thanks 3dickulus !   A Beer Cup A Beer Cup A Beer Cup A Beer Cup A Beer Cup A Beer Cup

i would like to provide an executable with your hack , but i got some errors ( see bellow) when i try to compile fragmentarium with the code you provided.
on my side i'm not able to define where is the problem  hurt

edit: i added the rapport if it can help !


* Screenshot - 04_07_2013 , 22_02_47.jpg (45.48 KB, 1380x120 - viewed 366 times.)
* BuildLog.zip (3.66 KB - downloaded 141 times.)
« Last Edit: July 04, 2013, 10:11:44 PM by vinz » Logged
3dickulus
Global Moderator
Fractal Senior
******
Posts: 1558



WWW
« Reply #27 on: July 04, 2013, 10:11:44 PM »

looks like you need to add the QtSpline.cpp and .h files to the projects sources list

there should be a menu item somewhere that say something like "Add file to project"

Logged

Resistance is fertile...
You will be illuminated!

                            #B^] https://en.wikibooks.org/wiki/Fractals/fragmentarium
vinz
Iterator
*
Posts: 154


« Reply #28 on: July 04, 2013, 10:12:40 PM »

ok i going to check that smiley
Logged
vinz
Iterator
*
Posts: 154


« Reply #29 on: July 04, 2013, 10:22:04 PM »

Ok, it stay only one error ! a step forward  embarrass
but it not clearly explained on the outpout windows.

so i added the rapport here.

* BuildLog.zip (2.77 KB - downloaded 156 times.)

* Screenshot - 04_07_2013 , 22_19_11.jpg (60.56 KB, 1165x228 - viewed 364 times.)
Logged
Pages: 1 [2] 3   Go Down
  Print  
 
Jump to:  


Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines

Valid XHTML 1.0! Valid CSS! Dilber MC Theme by HarzeM
Page created in 0.129 seconds with 28 queries. (Pretty URLs adds 0.007s, 2q)