News: Check out the originating "3d Mandelbulb" thread here
 
*
Welcome, Guest. Please login or register. September 21, 2017, 12:06:04 AM


Login with username, password and session length


The All New FractalForums is now in Public Beta Testing! Visit FractalForums.org and check it out!


Pages: [1]   Go Down
  Print  
Share this topic on DiggShare this topic on FacebookShare this topic on GoogleShare this topic on RedditShare this topic on StumbleUponShare this topic on Twitter
Author Topic: ubuntu gnome 17.4, mandelbulber 2.11-1 cannot enable gamepad support at compile  (Read 121 times)
0 Members and 1 Guest are viewing this topic.
JerryS
Forums Newbie
*
Posts: 2


« on: August 24, 2017, 02:05:59 AM »

Hi, just hoping for some help getting qmake to find the gamepad libraries. I followed the README and INSTALL files and got it to compile, but the only optional feature that it recognized was sound. Do I need to install some other -dev library? I've looked for everything I could think of in synaptic, and googled every combination of words I could think of on the topic. The gamepad itself works properly in jtest-gtk. Please help because I want to use my gamepad.
Logged
zebastian
Conqueror
*******
Posts: 118



« Reply #1 on: August 26, 2017, 01:59:27 PM »

Hi Jerry,

can you run the following cmd in a terminal:

qmake --version

and paste the results?

BTW: jtest-gtk uses SDL library.
Mandelbulber uses the qt gamepad module, which in turn uses different backends when available. This makes it cross platform working on osx, windows, linux.
Logged
JerryS
Forums Newbie
*
Posts: 2


« Reply #2 on: August 26, 2017, 10:37:32 PM »

Code:
[snip]makefiles$ qmake --version
QMake version 3.0
Using Qt version 5.7.1 in /usr/lib/x86_64-linux-gnu
Logged
zebastian
Conqueror
*******
Posts: 118



« Reply #3 on: August 30, 2017, 11:39:13 PM »

hi jerry,

for fedora i needed zo install

qt5-qtgamepad qt5-qtgamepad-devel

I could not find the package for ubuntu, so it is probably somewhere bundled in some other  qt* package.
@buddhi do you still know, which module you needed to install for the gamepad?
Logged
Pages: [1]   Go Down
  Print  
 
Jump to:  

Related Topics
Subject Started by Replies Views Last post
Fractals Enable Wideband Invisibility Cloak Fractal News across the World Nahee_Enterprises 1 941 Last post December 08, 2009, 01:28:01 AM
by Saquedon
Ubuntu Render program ? Help & Support mrrgu 0 474 Last post December 18, 2009, 03:34:23 PM
by mrrgu
Relocated: Ubuntu Render program ? Meet & Greet Nahee_Enterprises 0 597 Last post January 06, 2010, 05:34:33 PM
by Nahee_Enterprises
Mandelbulber 1.09 - experimental OpenCL support Releases Buddhi 9 4075 Last post December 21, 2011, 09:15:18 PM
by Loadus
Installing Mandelbulber OPenCL on Ubuntu Other / General Discussion abtechno 2 1910 Last post March 13, 2014, 08:07:26 AM
by quaz0r

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines

Valid XHTML 1.0! Valid CSS! Dilber MC Theme by HarzeM
Page created in 0.248 seconds with 28 queries. (Pretty URLs adds 0.01s, 2q)