Logo by yv3 - Contribute your own Logo!

END OF AN ERA, FRACTALFORUMS.COM IS CONTINUED ON FRACTALFORUMS.ORG

it was a great time but no longer maintainable by c.Kleinhuis contact him for any data retrieval,
thanks and see you perhaps in 10 years again

this forum will stay online for reference
News: Visit the official fractalforums.com Youtube Channel
 
*
Welcome, Guest. Please login or register. January 20, 2021, 02:52:28 PM


Login with username, password and session length


The All New FractalForums is now in Public Beta Testing! Visit FractalForums.org and check it out!


Pages: [1]   Go Down
  Print  
Share this topic on DiggShare this topic on FacebookShare this topic on GoogleShare this topic on RedditShare this topic on StumbleUponShare this topic on Twitter
Author Topic: Mandelbulber on Windows 8  (Read 1126 times)
Description: Issue with writing settings files
0 Members and 1 Guest are viewing this topic.
Mihaly
Forums Newbie
*
Posts: 8


Rose Red and Leafy Green - go figure


WWW
« on: July 10, 2014, 09:50:52 PM »

 Hi everybody, am not sure if this has been raised (it may have occurred with windows 7 or earlier versions too) but I wanted to raise an issue I had when I set up mandelbulber in my windows 8 system, that it seemed that I couldn't store files in the standard directory - that /is/ a windoes protection issue, that's right - but what I found was that I also had problems getting the correct loading of either the background orthe texturefiles, and a slight issue with generating thumbnails in the load settings dialog.

 OK, ok, believe me I have nothing against this program, so I want to discuss this very carefully, both because I don't wish to raise what seems to be a bug when it could easily be something I have done wrong myself, nor do I wish to get into the OS war kind of distraction.

 I should say firstly that I may have transferred across some older files, because looking at the examples I found they were from version 1.16, and I feel sure I have been using the program and may have save files from as early as v1.02 !!  I'm currently using version 1.21

 I mention it because it was what I experienced, and maybe others may find it also (actually it may be a moot point given  that there are upcoming changes I now learn).
 
 So the issue seems to be between setting and saving settings files, but being unable to load new files that include the correct directories for the texture, background, etc paths.

 You can set them manually in the GUI, but even after it saves, it apparantly doesn't actually save or didn't write the new settings into the existing file (possibly because Win 8 protection doesn't allow it to - OK) but why no "error saving file" or "cannot write file" dialog then? It looks to have failed silently. Perhaps it should.

 Probably I should have installed it correctly? Might just be a slight overlooking that the defaults for the paths appear to have mixed directory delimiters. that is, if you look at the waythe paths are under default setup, I get for images: /images/image
for texture: C:\Users\mihaly/texture.png   <- Note i) mixed fore- and back-slashes !!!
for background: C:\Users\mihaly/background.png
for LightMap: C:\Users\mihaly/lightmap.png
for paths: /paths/path.txt
for keyframes: /keyframes/keyframe

 And this keeps coming back, even after I adjust the paths literally one by one, clicking OK each change
then saving to the same startup file, then when I startup again it hasn't changed!

 I found this most frustrating, and eventuallyresorted to changing the examples by /hand/.

 However, I realise this may be an issue with how I have set up my machine, but it occurred to me that in windows XP youare allowed to establish a startup file inside (say) C:\Documents & Settings\Mihaly\
although the usual practice is to put the programs config/working directory into the My Documents folder that lies underneath it.

 There may be conventions about this, depending on whether you want the user ofthe software to be able to look into those folders or whether they should remain transparent to the user of the software, but available to the program itself.

 So I imagine that in the installer program, the installer uses %HOMEPATH% or %APPLICATIONPATH% or some such to establish where these folders should be, but the inheritence of permissions in Windows 7 and 8 (read UAC- User Account Control) makes it impossible for a program to alter these files (short of giving it the adminstrator privileges, and in fact that may not even be the best solution either).

 It may be my fault for installing several versions and carrying them across so this issue may not appear for other users, but if it does, might I suggest that someone look into whether the Windows 8 installer is doing the correct thing?

 Please don't take this as anything other than just my own experience and question, I could have made my own errors so it may no longer be an issue, and I have no complaints about the software itself. It's just that I found this annoying problem, and was wondering whether anyone also found this to be the case.

 Also, I'd like to ask if there is a better solution than me hand-editing some 50 text files, although I tend to be brutish in my solutions, no subtlety from me, I fear.

 Feel free to call me out if I have the wrong idea here, won't be the first time I've been foolish, and I am pretty certain it wont be the last either.

 Still, I feel privileged to be amongst your fine company, and wish you all well in your fractal enthusiasm.
(seriously- I actually do talk this way smiley
Mihaly K.
 cheesy
Logged

the things we can't give away
but have no use for
hold every man back
for what they die for
ellarien
Conqueror
*******
Posts: 123


I like flowers


WWW
« Reply #1 on: July 10, 2014, 11:09:53 PM »

I had much the same trouble with a clean install of the previous version on Windows 8.1, so it isn't just you. I did get the program installed in the Program Files (x86) folder, even though both Windows and my antivirus tried quite hard to stop me, but the paths thing was still an issue with the examples. It didn't stop me enjoying the program.
Logged
JohnVV
Conqueror
*******
Posts: 123


having fun


« Reply #2 on: July 12, 2014, 08:27:21 AM »

Microsoft royally messed things up with the UAC in 7
if programs are installed to " c:\\Program Files " the messed up uac can stop the program from writing to the install folder in " c:\\Program Files "

install Mandelbulber to
C:\\Mandelbulber

then a non root user can save to the install folder

This has been an ongoing FUBAR problem that Microsoft created themselves
Logged

Running OpenSUSE 42.1-64bit & ScientificLinux-6.7-64bit
I don't pitch Linux to my friends,I let Microsoft do it for me!"
Buddhi
Fractal Iambus
***
Posts: 895



WWW
« Reply #3 on: July 25, 2014, 02:49:43 PM »

Microsoft royally messed things up with the UAC in 7
if programs are installed to " c:\\Program Files " the messed up UAC can stop the program from writing to the install folder in " c:\\Program Files "

It's not UAC problem. It's Windows users problem, who can't understand basic protections implemented in modern Windows systems. First of all the application mustn't save any data to program folder and it's directories inside Program Files. It gives the best protection against viruses and other treads.
In my opinion Microsoft not messed things but resolved the biggest Windows problem. Now it's molstly safe like under Linux.

I have just tested the program under Windows 8 and installation went without any issues and the program works perfectly (even with OpenCL).
I tried to use different textures, save settings, create animation. There was no any problems.

I think I know what you tried to do. You wanted to modify example files. They are located in Program Files folder, so they are write protected. However what is the problem to save own copy of setting file in your user directory (C:\Users\....\mandelbulber\settings\....) or in any other folder where you have an access.

About slashes and backslashes, this application allow to use both. It's based on MinGW (originally from Linux), so it translates it.

If my understanding of your problem definition is wrong, please correct me and I will try to answer again. If there is really some problem with application, I will try to correct it in Mandelbulber v2 which is actually under development.
Logged

ellarien
Conqueror
*******
Posts: 123


I like flowers


WWW
« Reply #4 on: July 25, 2014, 03:35:28 PM »

There is a small problem with the paths -- not so much with the program itself as with some of the examples files. On my 64-bit system the program installed to c:\program files (x86) but some of the examples expect the background images to be under c:\program files. (power-2 limits.fract, for example.) I guess a workaround would be to assume administrator privileges for long enough to copy the textures etc. to the directory where the examples expect them to be. wink

I'm looking foward to the release of version 2. smiley

Logged
Pages: [1]   Go Down
  Print  
 
Jump to:  

Related Topics
Subject Started by Replies Views Last post
Mandelbulber 1.05 - with Windows installer Releases Buddhi 3 2027 Last post July 11, 2011, 10:20:49 PM
by taurus
Mandelbulber 1.061 - for Windows 64-bit Releases « 1 2 » Buddhi 16 4980 Last post August 10, 2011, 12:33:35 AM
by ihcn
Mandelbulber 1.13-1 - NetRender also for Windows Releases « 1 2 » Buddhi 17 15873 Last post April 24, 2013, 07:59:41 PM
by Buddhi
Building Mandelbulber on Windows with Visual Studio Mandelbulber neosettler 7 2247 Last post May 12, 2013, 01:17:10 AM
by JohnVV
Building Mandelbulber under Windows 7 64bit (with mingw/gcc) Mandelbulber rh73 5 3274 Last post April 12, 2014, 01:53:58 PM
by rh73

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines

Valid XHTML 1.0! Valid CSS! Dilber MC Theme by HarzeM
Page created in 0.203 seconds with 29 queries. (Pretty URLs adds 0.009s, 2q)